in System Integration by


I am building an application where the user will connect to a certain WiFi network. In order to implement the navigation from one scrren to another, I have used the modal GUI components. (If there is a better way, please let me know.) According to the documentation, when BeginModal is called, then whaterver was active is not taking any user inputs anymore. The active screen is the modal one.

Based on the example "creating-the-application-component-2", I have implemented the modal groups. I have attached the project so thatyou can open it.

Up to this point I have implemented two levels of modals. First, when you select the WiFi button, all the available networks are shown. Then you can select a certain network to open the screen where you should type te password.

I have noticed that the buttons from the previous screens can still be pressed, even thou a modal group has been added to the view. You can check that by clicking inside the password box in the password screen. It seems to activate the WiFi selection button, which is indeed two layers down.

I hope the explanation is clear enaough to help you see the problem in the project attached.

Thank you very much for the support.




1 Answer

0 votes
Best answer

Hello Gazi,

because of few missed files (e.g. wifi_big.png, etc.) I was not able to test your application. Nevertheless I reviewed it and found the potential cause of the issue. Please see the GUI components: Settings_main::Settings_main, Settings::Settings, Settings::Settings_main, Settings::Settings_Wifi. All these components are derived from the Core::Root class. For example:

Within a typical EmWi application it should be always one (single) component derived from Core::Root. All other components should descend from the Core::Group class. Please see also: Assembling the application. I suppose, when adding the components for Settings, etc. to the project you have mixed the Application with Component template:

How to correct this?

When you select the bricks representing the components (e.g. Settings_main) you see in Inspector window its attribute SuperClass. Just change this attribute to the value Core::Group as shown below. Repeat this operation for all above mentioned components.

Does it solve the issue?

Best regards

Paul Banach

Hi Paul,

Thanks a lot for the response. I just changed all the Root::Core to Root::Group for all components, except the Application.

It solved the issue. Thank you very much.



Embedded Wizard Website | Privacy Policy | Imprint