STM32F7 Example Build not working

413 views
asked Dec 6, 2016 in Getting started by kenny-r
When I try to buil I get the error 'STM.STM32Fx.RGB565' does not provide the code generation module 'codegenerator.ewm'. I have followed all the STM32F7 getting started steps.

1 Answer

0 votes
answered Dec 6, 2016 by Manfred Schweyer

Please open your project (e.g. 'HelloWorld') and select the profile brick within the Composer. Then have a look to the attribute 'PlatformPackage' within the Inspector. When you now open the drop-down list, you should see a couple of Win32 Platform Packages and a couple of STM32Fx Platform Packages, e.g. STM.STM32Fx.RGB565.

If the STM32Fx Platform Packages are missing, it seems that the STM32Fx Platform Package is not installed.

commented Dec 27, 2016 by kenny-r

It seems that the platform packages are missing. How do I download the packages?

I have followed these steps:

http://ask.embedded-wizard.de/241/getting-started-with-stm32f746-discovery

 

I have also been trying to recreate your steps in this video:

https://www.youtube.com/watch?v=BJ6oXZlA7X8

However, when I click on StartBuildEnvironment.Bat I get the following error:

Btw I have installed ARM GCC toolchain and placed several different directories and nothing has worked!

commented Jan 9, 2017 by Manfred Schweyer

Please verify, that the GCC toolchain, the STM32Cube software and the STM32F746 Build Environment are installed within one common directory.

As you can see within your screenshot, the STM32F746 Build Environment is a subdirectory within the STM32Cube_FW_F7 directory.

Please try to follow exactly the description, then it will be very easy to build all the provided examples.

 

Ask Embedded Wizard

Welcome to the question and answer site for Embedded Wizard users and UI developers.

Ask your question and receive answers from the Embedded Wizard support team or from other members of the community!

Embedded Wizard Website | Privacy Policy | Imprint

...