Problem to get my first Embedded Wizard UI application up and running on an STM32F769 Discovery board.

709 views
asked Dec 7, 2016 in Getting started by echo

I followed the steps:Getting started with STM32F769 Discovery;I have problems in step:Compiling, Linking and Flashing:

Start the batch file 'StartBuildEnvironment.bat'. As a result, a windows command line window should open. The starting directory location is \Examples.

the problem is that I had tried this,but there is no windows command line window opened,just flashed across!!!

who can help me?

1 Answer

0 votes
answered Dec 7, 2016 by Manfred Schweyer

Hi, please try the following:

Open a Windows command line window and navigate to your build directory, into the subdirectory /Build. Then insert the command 

StartBuildEnvironment.bat

What is the result printed within the command line window?

commented Dec 8, 2016 by Manfred Schweyer
Please open the file Core.c and let me know the following parameters that are written at the beginning of the file:

* Version  : 8.00
* Profile  : STM32Fx
* Platform : STM.STM32Fx.RGB565

Do you have the same results?
commented Dec 9, 2016 by echo

No,my results are:

* Version  : 8.00
* Profile  : STM32Fx
* Platform : Tara.Win32.RGBA4444

commented Dec 9, 2016 by echo

I have copied a new project,and when I press F8 for building it,there is an error:

[9.12.2016 13:16:15] Information Generating code for the profile 'STM32Fx' ...
[9.12.2016 13:16:15] Fatal error Can not generate code. The currently selected platform package 'STM.STM32Fx.RGB565' does not provide the code generation module 'codegenerator.ewm'. Possibly the necessary platform package is not installed on your PC or the name of the platform package 'STM.STM32Fx.RGB565' is invalid.
 

commented Dec 9, 2016 by Manfred Schweyer
Ok. So the reason is the following:

On your system, the STM32Fx Platform Package is not installed. In order to avoid the error message  within the HelloWorld project you changed the profile attribute 'Platform Package' to 'Tara.Win32.RGBA4444'. But this code cannot be compiled for STM32 targets...

Please install the 'STM32Fx Platform Package' as written within the Getting Started document.

Does it work?
commented Dec 10, 2016 by echo
OK ,It works now,thank you very much!

Ask Embedded Wizard

Welcome to the question and answer site for Embedded Wizard users and UI developers.

Ask your question and receive answers from the Embedded Wizard support team or from other members of the community!

Embedded Wizard Website | Privacy Policy | Imprint

...