37 views
in GUI Development by

Hello,

 

I got some Issue using Attributed Text (grey). There is a different behavior then the "standard" Text View (white). It Seems the problem just exists with the usage of True Type Font Engine. We are using EW9.30.

True Type Font Engine (Open GL)Windows

Both Views have the same Font with a height of 120. In both cases the Alignment is Horizontal and Vertical Center. It seems that the Attribute Text height is much higher then the specified 120 and for this reason the text does not fit in the widget. There is no Padding and Scroll Effect defined. A known issue is, that the difference of the Font Resources of OpenGL and Windows causes a difference in the actual text size.

Is this a bug or is there any reason for this behaviour? How can I get the "real" height of the Attributed Text to fit in the widget? 

 

Best Wishes Jonas

1 Answer

0 votes
by
Hello Jonas,

I tried to reproduce the issue, but without success. Which font are you using? Or better, can you provide a small project (inkl. the TTF/OTF file) demonstrating the problem?

Best regards

Paul Banach
by
Hello Paul,

we are using a non common font. Maybe there is some issue with the resource. Actually other fonts are looking well.

I send you the resource via mail.

Ask Embedded Wizard

Welcome to the question and answer site for Embedded Wizard users and UI developers.

Ask your question and receive answers from the Embedded Wizard support team or from other members of the community!

Embedded Wizard Website | Privacy Policy | Imprint

...