92 views
in Embedded Wizard Studio by

When try to execute the automation test case using Start Prototyper - Getting the below error.

if ( aView == null )
  throw "No view to add";

 

 

Kindly help.

1 Answer

0 votes
by
Hello Thushar,
Please use 'Start Prototyper with application class' to start the tests in Prototyper mode.
According to the described error, you want to 'Add' a view which was not created. Please check within th callstack why 'null' was passed to the parameter 'aView'.

With kind regards,
Rudolf
by

Hi ,


Thanks for you reply.
Yes we are calling with Application class only. With same configuration my colleague is able to execute. Below are the errors found.

[14.10.2022 10:00:58] Error Test::NativeClass.GetCurrentDirectory (4:20) : Call to an unknown method 'EmWiTestOsGetCurrentDirectory()'.
[14.10.2022 10:00:59] Error : Can not initialize a new object. The constructor of the class 'Test::RunnerApplication' is failed.
[14.10.2022 10:00:59] Runtime Core::Group.Add (2:3) : Chora exception: 'No view to add'.

I am getting the below pop up while Starting.

 

When I select Don't load now, I am getting the above errors. 

When I select Load only once, it is successfully executing. Kindly let me know what is the above dialog (Load Intrinsic dialog). Is it ok to provide the option Load always? 

 

Thanks,

Thushar

by
Hi,
please select 'Load always' to allow Embedded Wizard to load the TestV1100.ewi' Intrinsic module. This is part of the test framework and must be loaded.

With kind regards,
Rudolf
by
Thank you Team.

Regards,

Thushar

Embedded Wizard Website | Privacy Policy | Imprint

...