15 views
in GUI Development by
Hi,

I have string table to generate string .

strings.ewu file was generated but when i open the application Sting unt is crashed

I am facng below mentioned error

Fatal error D:\Phase4\updated_code\code\Product_Software\Source\EmbeddedWizard\Strings.ewu (13:22) : Delimiter '=' expected.
[22.6.2022 18:35:14] Fatal error Strings : The loading of the unit 'Strings' is failed.

please guide me to resolve this

 

With regards

Ramesh.g

1 Answer

0 votes
by
Hi Ramesh,

can you please send me the String.xlsm excel sheet your are using to generate the strings?

Regards,

Julian
by

Hi,

    Here i ahve attached string.xls.please verify it

 

https://ask.embedded-wizard.de/?qa=blob&qa_blobid=2522773335329198808

 

With Regards

Ramesh.G

by

String.xls have some empty rows .now i removed the empty rows..

https://ask.embedded-wizard.de/?qa=blob&qa_blobid=4955301320765186574

ago by

Hi Ramesh,

I found two issues:

1. Set the header row to 1 and not to 2:

2. Please make sure that all your string-ids do not include blanks. I prefer the camel case style like: PatientId, but separation by underline is also fine like: Patient_ID

Your generated strings.ewu should than look like the following:

Best regards,

Julian

 

 

ago by
Hi,

     I have modified the string table as per your suggestion but still i am getting the issue

issue :

EmbeddedWizard\Strings.ewu (29:14) : Delimiter '=' expected.
[28.6.2022 11:05:00] Fatal error Strings : The loading of the unit 'Strings' is failed.
ago by
Hi,

can you please attach your current strings.xls.

Regards,

Julian
ago by

Hi,

   Here i have attched my string.xls.please verfy it.

https://ask.embedded-wizard.de/?qa=blob&qa_blobid=16693386275812043253

 

With Regards,

Ramesh.G

ago by

Hi Ramesh,

please also do not separate the languages by blankes. In this case "Simplified Chinese".
Than I see a lot of blanks at your strings-ids like: "Date _of_birth", "  Mandatory_fields"
"24-hr-Format" does not work because the "-" is not supported and the string-id is not allowed to start with a number.

I have not checked further, but I assume that there are more non-loadable string-ids in.
EmWi gives you a hint where they are at the end of the error message.

EmbeddedWizard\Strings.ewu (29:14) : Delimiter '=' expected.

This means the error is located inside Strings.ewu at line 29. Open this file inside a texteditor and you will find there the strings-id thats not loadable. You can than fix it inside the strings.xls.

In general, if you are using only the characters [a-z], [A-Z] and digits for your string-ids you should be good.

Regards,

Julian

Ask Embedded Wizard

Welcome to the question and answer site for Embedded Wizard users and UI developers.

Ask your question and receive answers from the Embedded Wizard support team or from other members of the community!

Embedded Wizard Website | Privacy Policy | Imprint

...